The start of the major issues!

January 1, 2018

I was riding on an elevated section of freeway when I noticed the temp gauge suddenly start to climb. I rolled off the throttle and was assesing the problem when the gauge started to move to the cold position! I knew immediately that I had a probable coolant leak. I was not able to stop as there are no places on the elevated section to pull over. I was close to my exit so I gingerly made that exited the skyway and as soon as possible came to a stop. At first I could find nothing wrong but after a little bit of searching I found a split in a coolant hose! Dam. Again, no spares available, no rescue so I spent a day looking for a length of hose to modify so I could at lease get the bike home. At long last, I managed to fashion a pipe and manged to get the bike home. I did not want to run it again untill the complete set of new coolant pipes I had ordered arrived. 3 week wait! On inspecting all the coolant pipes it become obvious that althogh they looked in perfect condition on the outside, on the inside they were all rotted. I waited for the replacement parts praying that I had not damaged the engine. I also needed to order many different fastners for the fairings and many other places. It seems that during the time it was parked up the previous owner had had a mechanic remove the fairing and other parts to do routine servicing but he had not bothered to tighten them up. I lost many nuts/ bolts and fastners during the first few weeks. As I only use genuine Kawasaki parts they all had to be ordered online. (Thanks to Cornwall Kawasaki for all the help they have been to me over the last couple of years.

Share on Facebook
Share on Twitter
Please reload

Featured Posts

I'm busy working on my blog posts. Watch this space!

Please reload

Recent Posts

October 29, 2019

August 9, 2019

Please reload

Archive